Too Cool for Internet Explorer

Configurar un iPod Nano de 6ª generación en GNU/Linux

Hora y Fecha: Diciembre 29, 2007 @ 9:22 pm Autor: Moisés Maciá
Categorías:
1,141 views

Actualización: Me confirman que el iPod Nano es de 3ª generación y no de 6ª como creía. En cualquier caso, esta guía es para los dispositivos nuevos.

Recientemente Apple ha cambiado el protocolo de comunicación de los iPod, presumiblemente para evitar el acceso a cualquier aplicación de terceros excepto iTunes. Esta actualización afecta a todos los dispositivos nuevos que lanzaron después de verano: iPod Nano, iPod Touch, Classic y algún otro.

Si utilizáis un iPod 6g en Linux, podreis sincronizar la lista de canciones pero después el dispositivo no puede leerlas. Los desarrolladores de libgpod y Amarok rápidamente han actualizado el software para permitir el uso de todos estos dispositivos desde sistemas libres, concretamente hace falta la versión 0.6 de libgpod y la 1.4.8 de Amarok.

Configuración en Ubuntu/Debian

  • Actualiza tu sistema a la última versión. Ubuntu Gutsy trae Amarok 1.4.8
  • Descarga e instala el paquete libgpod3 de los repositorios de Hardy (funciona sin problemas de dependencias en Gutsy). Otra opción es bajar el código fuente y compilarlo tu mismo, solo para desarrolladores o desesperados :)
  • Amarok esta linkado a la antigua versión de libgpod, para que utilice la nueva es necesario actualizar el symlink:
    1. sudo ln -fs /usr/lib/libgpod.so.3 /usr/lib/libgpod.so.2
  • Conecta el iPod y montalo.
  • Abre un terminal y escribe el comando:
    1. sudo lsusb -v | grep -i Serial

    Aparecerá un hash de 16 caracteres, ese es el identificador de dispositivo que utiliza iTunes para “cifrar” la lista de canciones. Cópialo.

  • Edita un archivo que se encuentra en el sistema de archivo del iPod, en la ruta /media/IPOD/iPod_Control/Device/Sysinfo. Si no existe créalo.
  • Escribe FirewireGuid: 0x... y el número de identificación de tu iPod. En mi caso queda así:
    1. ModelNumStr: xA426
    2. FirewireGuid: 0×000A27001B09504F
  • Abre Amarok, gtkPod, o tu reproductor libre de música favorito, configura el iPod con normalidad, pasa algunas canciones y disfruta de la música.

Links:

PD. No, no me he comprado un iPod, ha sido una petición especial que comenzó con la frase “A que no tienes cojones a …”.
PD2. Gracias Apple por acordarte de todos aquellos que no pueden ni quieren utilizar iTunes.





« Anterior post: IE8, campeón | Próximo post: Quickies »

7 Comentarios para “Configurar un iPod Nano de 6ª generación en GNU/Linux”

meneame.net
29 de Diciembre de 2007 a las 9:32 pm    

Configuar un iPod Nano de 6ª generación en GNU/Linux…

Recientemente Apple ha cambiado el protocolo de comunicación de los iPod, presumiblemente para evitar el acceso a cualquier aplicación de terceros excepto iTunes. Esta actualización afecta a todos los dispositivos nuevos que lanzaron después de ver…

[...] Si quieres configurarlo sólo tienes que leer este post en QuarkBlog. [...]

Marco
7 de Enero de 2008 a las 12:33 am    

Muchisimas gracias, ya me estaba viendo temiendo yo que para utilizar el nuevo ipod (que me han traido los reyes) iba a tener que instalarme Windows..

Fernando Sánchez
1 de Abril de 2008 a las 7:15 pm    

Hola!

Sólo quería recalcar la importancia de seguir estrictamente *todos* los pasos que describes aquí. Tras leer tu artículo, intenté configurar mi Nano Video de 8GB en mi Ubuntu Gutsy (7.10) y dos cosas me han estado tocando las narices durante dos días:

- El tema de instalar el libgpod desde el código fuente y no el del repositorio por defecto de Gutsy con un simple apt-get install. Según tu post, con la de Hardy también funciona. Yo leí demasiado rápido el artículo y me quedé con “repositorio”. Consecuencia: no salían las portadas de los discos por mucho lío que montara. Será porque la versión de Gutsy todavía no tenía en cuenta el modelo nuevo de nano.

- El tema del soft link desde /usr/lib/libgpod.so.2 a libgpod.so.3. En plan listo, pensé que era una errata y dejé el libgpod.so.2 apuntando a libgpod.so.2.0.0 y el libgpod.so.3 apuntando a libgpod.so.3.0.0. Resultado: el ipod no veía ningun fichero mp3 a pesar de que aparecían en amarok y en gtkpod.

Así que aviso para navegantes: no hagan el zangüango como hice yo y sigan éstos pasos (o éstos otros http://ubuntuforums.org/showthread.php?t=619615&page=4 , que son los mismos pero con un comando que ahorra el editar a mano el fichero del interior del iPod) LITERALMENTE, y disfruten de su ipod librándose de tener que usar iTunes.

Quizá haya perdido un par de ratos, pero comparado con sufrir iTunes a diario ha merecido la pena. Vaya que sí…

un cordial saludo
Fernando

[...] Pasos para poder usar el ipod de 3º Generación en Amarok. « Qué asco de ilusiones   [...]

sol
11 de Abril de 2008 a las 8:17 pm    

Hola! muchas gracias, es que ya no sabia que hacer para poner configurar el ipod y justo llegue a esta pagina, me salvaron el dia…ya casi me estaba bajoneando

[...] Leí como hacerlo en el siguiente enlace [...]


Bad Behavior has blocked 497 access attempts in the last 7 days.